О программе

 Программа NVProg предназначена для обновления версий GSM передатчиков NAVIgard 2050/291, мониторингового GSM приемника NAVIgard DATA и расширителей NAVIgard 2051. Обновление достигается за счет программирования главного процессора, управляющего изделием.
Что необходимо для обновления версии.


Что необходимо

 Для обновления версии необходимо:

модуль согласования NAVIgard 1225
прямой соединительный кабель для COM порта (удлинитель COM порта)
файл с обновленной версией прошивки

Функцию обновления поддерживают GSM передатчики NAVIgard 2050/291 начиная с версии 5.01. То есть версию 4 и ниже обновить нельзя.


Последовательность действий

 Последовательность действий при программировании:

Установить связь с передатчиком.
Выбрать файл с обновленной версией.
Программировать.


Установка связи

 Подключите передатчик NAVIgard 2050 к COM порту Вашего компьютера с помощью прямого соединительного кабеля (удлинителя COM порта) и модуля согласования NAVIgard 1225. Перемычки на плате NAVIgard 2050 не нужны. Установка связи с передатчиком возможна только в течении 2 секунд после его включения. Поэтому последовательность действий такова:

1) Выключить передатчик если он включен
2) Нажать кнопку "Связь"
3) Включить передатчик

Если связь не установилась, необходимо проверить кабель, соответствие выбранного и подключенного COM порта, нынешнюю версию передатчика и повторить все сначала.
После установки связи необходимо открыть файл с обновленной версией.


Выбор файла

 Выберите в меню Файл - Открыть или нажмите кнопку "Открыть файл". Выберите файл с обновленной версией прошивки для изделия. Имя файла включает название изделия и версию, расширение файла *.hhx. Например, файл для GSM передатчика NAVIgard 2050 версии 5.02 называется

2050v5_02.hhx.

Файл с обновленной версией можно получить на сайте производителя или обратившись в техподдержку.
Затем нажмите Программировать.


Программирование

 Нажмите "Программировать". Если во время программирования случилось что-то непредвиденное, например, сбой напряжения питания, то всю процедуру необходимо повторить сначала.